This project is read-only.
Documentation is under construction

Standard Installation

Dependencies

RAIP depends on the following packages:

To check whether any of the above packages are already installed on your system, try:

$ python
>>> import numpy
>>> import scipy
>>> import matplotlib
>>> import networkx
>>> import cplex
ImportError means the package is not installed.

Install dependencies on unix-like systems:

  1. Use your package manager to install the required python packages; for example on Debian/Ubuntu:

$ sudo apt-get install python-numpy
$ sudo apt-get install python-scipy
$ sudo apt-get install python-matplotlib
$ sudo apt-get install python-networkx

  1. Download and install the IBM ILOG CPLEX Optimizer:
For testing purposes a trial version can be found here. If you want to have full functionality you need to register at ibm.com and get a licenced copy.


Last edited Dec 4, 2012 at 3:02 PM by jhooge, version 5

Comments

No comments yet.